Invalid AccountingCategoryId
Resolution:
Verify the Product Accounting category is active in Thynk and Mews and that it belongs to the correct property
Re-activate the Accounting category in both Thynk and Mews or assign different active Accounting Category to the Product
If the Accounting category is changed on the Product, update the Accounting category on the Order line as well and check ‘Send to Mews’ again
Invalid ServiceId
Resolution:
Verify the Service is active in both systems Mews and Thynk and belongs to the right property.
Re-activate the Service in both Thynk and Mews or assign a different active Service to the Product.
Verify the Service type is set to ‘Orderable’ and not ‘Reservable’. If it’s set to ‘Reservable’ select a different Service on the Product. ‘Reservable’ service can be used only for Hotel Rooms.
If the Service is changed on the Product, update the Service on the Order line as well, and check ‘Send to Mews’ again.
Invalid ProductId
Resolution:
Verify the Product is active in both systems Mews and Thynk, and that it belongs to the correct property.
Re-activate the Product in both Thynk and Mews, or create a new Quote Product using an active Product.
If a new Quote Product is added to the Quote, click on the ‘Update Order’ button.
If the Product has been reactivated again, check ‘Send to Mews’ on an existing Order.
"Invalid AccountId.","DebugDetails":null,"Details":null
Even though the error message says Invalid AccountId, in reality it's the Reservation Guest that is missing on Booking and further on the Orders.
Possible cause:
PMS Account linking Process failed which caused the Reservation Guest Process not being fired
Link the Existing PMS Account to the Booking >> This will fire the Reservation Guest creation Process.
If that's not the case, Create a Guest record where Guest.Name == 'Booking.Name', Guest.Property == Booking.Property, Guest.Send_to_Mews == True.
Once Guest receives Mews Id >> Link this guest record to the Booking into the Reservation Guest field.
Orders are updated. Guest is linked to the orders
To send the Orders to Mews >> Use the Update Order Button on the Booking
Resolution:
Verify the Group still exists in Mews. If not, remove the incorrect Mews Group ID from the Quote and click on 'Send Failed Reservations'
Resolution:
Verify the Reservation Guest exists in Mews (search by the Mews ID or search by name)
If unable to locate the record in Mews, it is likely that it has been merged with another customer.
To use the same Reservation Guest displaying the error in Thynk, open the Reservation Guest and remove the 1) Mews error 2) Mews Id 3) Mews Number
On the Reservation Guest record, tick the 'Send to Mews' checkbox. Mews will assign a new Mews ID and Mews number
Check ‘Send Failed Reservation’ on the Quote
Invalid TravelAgencyId
Resolution:
Verify the agent exists in Mews (search by the Mews ID)
If the Agent exists in Mews, confirm the Agent is setup as Travel agency in Mews, or the Agent has a Contract setup in Mews. Detailed setup instruction can be found here: https://help.mews.com/s/article/set-up-travel-agencies?language=en_US
Invalid CompanyId
Resolution:
Verify the Company exists in Mews (search by the Mews ID or search by name)
If unable to locate the record in Mews, it is likely it has been merged with another company.
To use the same Company displaying the error in Thynk, open the Company and remove the 1) Mews error 2) Mews Id, and 3) Mews Number
On the Company record, tick the 'Send to Mews' checkbox, Mews will assign a new Mews ID and Mews number
Check ‘Send Failed Reservation’ on the Quote
Invalid RateId
Resolution:
Verify the Hotel Room Rate is active in both systems Mews and Thynk, and that it belongs to the correct property
Re-activate the Rate in both Thynk and Mews, or assign a different active Rate to the Hotel Room
Check ‘Send Failed Reservation’ on the Quote
Invalid BookerId
Resolution:
Verify the Booker (Guest) exists in Mews (search by the Mews ID, or search by name)
If unable to locate the record in Mews, it is likely it has been merged with another customer
To use the same Booker displaying the error in Thynk, open the Booker and remove the 1) Mews error 2) Mews Id, and 3) Mews Number
On the Booker record, tick the 'Send to Mews' checkbox. Mews will assign a new Mews ID and Mews number
Check ‘Send Failed Reservation’ on the Quote
Invalid Release Date
Resolution:
Make sure the Quote Hotel room Release Date is in the future